Il team di sviluppo americano ha rilasciato la versione 1.5.0 Beta.

Essendo una BETA, non deve essere assolutamente utilizzata in ambito di produzione.

Come nostra consuetudine attenderemo che esca dallo stadio di BETA prima di distribuire la versione localizzata in italiano.

Chiunque voglia affiancare noi e migliaia di altri utenti nella fase di valutazione e individuazione di bugs al fine di accelerare il processo di uscita dalla BETA, è invitato a scaricare la distribuzione americana e procedere in autonomia al testing e ad effettuare eventuali segnalazioni secondo le procedure stabilite nel forum americano.

Ricordiamo ancora di non utilizzare la 1.5.0 BETA per siti in produzione.

Potete trovare tutti i dettagli, i requisiti di sistema, le procedure di report dei bugs, la documentazione e i download (aggiornati man mano) in lingua inglese a questo indirizzo: http://www.zen-cart.com/forum/showthread.php?t=183626

Qualche considerazione iniziale su questa nuova versione?

Dunque, come si vede dal changelog gli interventi sono innumerevoli. Moltissimi sono bugfixes, ma ci sono anche implementazioni di nuove funzionalità che nella quasi totalità dei casi hanno a che fare con la procedura per ottenere (a livello di software e poi per chi vuole a livello di sto) la certificazione di conformità agli standard PCI / PA-DSS, standard che governano la sicurezza dei dati e dei pagamenti: http://it.pcisecuritystandards.org/minisite/en/index.php.

Alcuni esempi:
- Admin profile integrato e migliorato
- Gestione password amministrazione con vincoli e scadenze (praticamente le stesse cose che prevede il nostro decreto sulla privacy).
- Gestione log amministrazione migliorata
- Rimozione htmlarea e fckeditor per obsolescenza
- disattivazione automatica del modulo carta di credito se il sito non è dotato di un certificato SSL lato frontend
- Implementazione supporto timezone (utile nei casi in cui il server sia in un paese con orario diverso da quello del negozio).

Come si vede, in attesa della versione 2.0 che porterà novità più 'appariscenti', questa è una versione che corregge svariati bug, migliora il funzionamento 'interno' e aumenta considerevolmente il livello di sicurezza dei nostri siti, aderendo ai più moderni standard internazionali.

Comunità Internazionale